[Identified and Resolved] Duplicate Email Remittance Notifications

Resolved

A temporary service disruption with our external email provider led to the delivery of duplicate email remittance notifications for payments issued on November 18, 2025 between 12:38PM and 12:50PM ET.

We confirm this issue is resolved.

Please be assured that this was an email delivery error only. All payments were processed correctly and only one time.
Posted Nov 18, 2025 - 20:28 EST