[RESOLVED] Positive Pay Requests Disruption

Resolved

The Positive Pay Payments issue for the J.P. Morgan plugin, caused by the length of vendor names in positive pay requirements, has been resolved.

Please advise affected clients they can process new payments. We apologize for any inconvenience this may have caused.
Posted Jun 26, 2025 - 20:02 EDT