Support Ticket Delays
Resolved
The root cause of the email delivery issue has been identified and remediated. We have been monitoring stability over the last 48 hours and can confirm that support correspondences are operating as expected. Thank you for your patience and understanding while we worked to resolve this issue. An incident report and root cause analysis will be provided.
Posted Sep 19, 2024 - 02:05 EDT
Monitoring
Our support functionality is fully operational, and we are no longer experiencing delays with our outbound email ticket replies . We are continuing to validate the root cause and monitor the situation to ensure stability.
Posted Sep 18, 2024 - 14:20 EDT
Update
We are continuing to investigate this issue with our ticket service provider. Our agents are utilizing a confirmed workaround in order to get support replies delivered to your clients.
Posted Sep 13, 2024 - 19:49 EDT
Investigating
We are currently experiencing an issue with our support ticketing platform that is affecting the delivery of some outbound replies. If you or a client have not received a response to your ticket, please follow up within the ticket, and our team will ensure that an agent contacts you promptly. We have escalated this issue with our ticket service provider and will provide updates as they become available. We sincerely apologize for the impact to you and your Clients.
Posted Sep 12, 2024 - 15:28 EDT