[SERVICE RESTORED] Payments Transmission Delays

Resolved

The issue affecting payment transmissions from FISPAN to the Bank's systems has been fully resolved. All pending payment transmissions have successfully cleared and normal processing have resumed.

We apologize for the inconvenience and appreciate your patience while we resolved this issue.
Posted Sep 04, 2026 - 16:59 EDT

Investigating

We have identified an issue with the sending of payments from FISPAN to the Bank's systems, which is causing a delay in payments being released to vendors.
We are actively investigating the problem and working to resolve it and further, will provide an update as soon as more information is available.
We apologize for any inconvenience.
Posted Sep 04, 2026 - 15:50 EDT